MM8.5及更高版本安装(升级)注意事项

在升级或安装ArubaOS 8.5.0.0以上时,一定要注意检查物理环境CPU是否支持SSE4.2指令集。这个内容在8500 Release note已经提到:

如果环境不支持,安装MM将出现“Datapath crashed collecting core and rebooting”错误,MM一直处于重启状态。8.3版本以下没有此问题。

关于CPU是否支持该指令集可以参考Intel网站:https://ark.intel.com/content/www/us/en/ark.html

SSE4.2是CPU硬件条件限制,如果不支持,切勿升级到8.5以后版本

如果VM虚机在群集(Cluster)中,请确保将EVC模式设置至少L2以上“ Nehalem”(最好选择最新的)。

为什么要这么做:EVC 模式会屏蔽 CPU功能。

具体参考: https://kb.vmware.com/s/article/1005764#What%20is%20EVC?

EVC开启方法:https://kb.vmware.com/s/article/2147821?lang=zh_CN

ESXi 各版本支持EVC模式情况参考:https://kb.vmware.com/s/article/1005764#What%20is%20EVC?

为什么控制器会Crash?

这是因为 x86 平台的 DPDK版本从 8.5. x 开始更新为 18.05,DPDK 从 17.0.8 版本开始需要 SSE4.2 在 x86 平台 (虚拟平台) 上运行, 更多信息: https://doc.dpdk.org/guides/rel_notes/release_17_08.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注